-
Enhancement
-
Resolution: Fixed
-
P5
-
None
-
b16
In a few places String.indexOf/lastIndexOf methods are called with default parameter for index: 0 for indexOf, length() for lastIndexOf.
I propose to cleanup such calls. It makes code a bit easier to read. In case of indexOf it even could be faster, as there is separate intrinsic for indexOf call without index argument.
I propose to cleanup such calls. It makes code a bit easier to read. In case of indexOf it even could be faster, as there is separate intrinsic for indexOf call without index argument.