Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8284016

Normalize handshake closure names

XMLWordPrintable

    • Icon: Enhancement Enhancement
    • Resolution: Unresolved
    • Icon: P4 P4
    • tbd
    • 19
    • hotspot

      There seems to be different naming conventions for handshake closures. A simple grep shows that most handshakes have Closure at the end of the name, some have HandshakeClosure, some have Handshake, and some just have handshake at the beginning.

      ShenandoahUpdateThreadClosure
      ShenandoahRendezvousClosure
      ZRendezvousClosure
      ZMarkFlushAndFreeStacksClosure
      GetSingleStackTraceClosure
      ReadMonitorsClosure
      TraceSelfClosure
      CloseScopedMemoryClosure
      EnterInterpOnlyModeClosure
      GetCurrentLocationClosure
      DeoptimizeMarkedClosure
      NMethodMarkingClosure
      HandshakeALotClosure
      TraceSelfClosure

      ShenandoahFlushSATBHandshakeClosure
      JvmtiHandshakeClosure

      EscapeBarrierSuspendHandshake
      InstallAsyncExceptionHandshake
      ThreadSelfSuspensionHandshake
      SuspendThreadHandshake
      AsyncExceptionHandshake
      UnsafeAccessErrorHandshake

      HandshakeForPD
      HandshakeForDeflation

            pchilanomate Patricio Chilano Mateo
            pchilanomate Patricio Chilano Mateo
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated: