-
Enhancement
-
Resolution: Unresolved
-
P4
-
20
currentTimeMillis() is not monotonically increasing. To me it seems sleep(timeout) would be much better (and easier to read).
This is most probably not related toJDK-8293289, a huge offset in time would be needed like daytime saving.
Although it is not causingJDK-8293289, it is still wrong.
change
```
// check timeout to success deadlocking
while(System.currentTimeMillis() < startTime + timeout) {
System.out.println("sleeping...");
sleep(1000);
}
```
to something like: `sleep(timeout)`
This is most probably not related to
Although it is not causing
change
```
// check timeout to success deadlocking
while(System.currentTimeMillis() < startTime + timeout) {
System.out.println("sleeping...");
sleep(1000);
}
```
to something like: `sleep(timeout)`
- relates to
-
JDK-8311639 Replace currentTimeMillis() with nanoTime() in jtreg/gc
-
- Resolved
-