Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8293515

heapShared.cpp: rename JavaThread parameter to current

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Fixed
    • P4
    • 20
    • 20
    • hotspot
    • b18

    Description

      https://github.com/openjdk/jdk/blob/1e031e6a5886fba3009d8e5fa62416fe15a901b6/src/hotspot/share/cds/heapShared.cpp#L826

      void HeapShared::resolve_classes_for_subgraphs(ArchivableStaticFieldInfo fields[], JavaThread* THREAD)


      The new convention is to rename THREAD to current, and also make it not the last parameter. This way the function won't be confused with one that takes a TRAPS parameter.

      Attachments

        Issue Links

          Activity

            People

              matsaave Matias Saavedra Silva
              iklam Ioi Lam
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 hour
                  1h