Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8294149

JMH 1.34 and later requires jopt-simple 5.0.4

    XMLWordPrintable

Details

    • b17

    Backports

      Description

        I noticed that the dependency for jopt-simple changed in JMH 1.34 from 4.6 to 5.0.4, but the devkit script was not updated in kind. I caught this as I was preparing a 1.35 bundle for use by jib. The 1.34 devkit we have deployed and use internally works on everything running in our CI, but subtly breaks down on more complex command lines

        Attachments

          Issue Links

            Activity

              People

                redestad Claes Redestad
                redestad Claes Redestad
                Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved: