Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8294430

RISC-V: Small refactoring for movptr_with_offset

XMLWordPrintable

    • Icon: Enhancement Enhancement
    • Resolution: Fixed
    • Icon: P4 P4
    • 20
    • 20
    • hotspot
    • b17
    • riscv
    • linux

        The name of function 'movptr_with_offset' looks misleading.
        It actually returns an offset to its caller.
        We could rename this function to 'movptr' so that it overloads existing function 'movptr'.

           void movptr(Register Rd, address addr);
        - void movptr_with_offset(Register Rd, address addr, int32_t &offset);
        + void movptr(Register Rd, address addr, int32_t &offset);

              fyang Fei Yang
              fyang Fei Yang
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Created:
                Updated:
                Resolved: