Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8294841

G1: Refactor predict_base_elapsed_time_ms

    XMLWordPrintable

Details

    • gc
    • b19

    Description

      This method needs some improvements:

      * remove the "elapsed" in the name of that method as that's confusing
      * split the sum statement into explicit parts so that some logging can be added
      * add logging about results
      * the result of this method is typically assigned to a variable called "survivor_base_time" - while the value contains evacuation time for current survivors, it's often only a minor part. Rename.

      Attachments

        Issue Links

          Activity

            People

              tschatzl Thomas Schatzl
              tschatzl Thomas Schatzl
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: