Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8295711

Rename ZBarrierSetAssembler::load_at parameter name from "tmp_thread" to "tmp2"

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Fixed
    • P4
    • 20
    • 20
    • hotspot
    • gc
    • b24
    • aarch64
    • linux

    Description

      On AArch64 and RISC-V, the last formal parameter for ZBarrierSetAssembler::load_at is named "tmp_thread". But the callers will pass an ordinary temporary register for this parameter which has no relation with the thread register. We should rename this formal parameter from "tmp_thread" to "tmp2".

      Attachments

        Issue Links

          Activity

            People

              fyang Fei Yang
              fyang Fei Yang
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: