Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8297532

[macos] Java Updater crashing after updating from 8u321 (or older) to -> 8u351

    XMLWordPrintable

Details

    • b01
    • x86
    • os_x

    Backports

      Description

        After upgrading my iMac to Ventura 13.0, the Java updater ran - however, it crashed with the following error. This has now happened 3 times, seems to be the same error each time.

        It seems to be a problem with the Sparkle library:
        > Termination Reason: Namespace DYLD, Code 1 Library missing
        > Library not loaded: @loader_path/../../../../Frameworks/Sparkle.framework/Versions/A/Sparkle

        I've attached the 1st and 3rd crash report as text files.

        Bringing up the Java control panel in System Prefs, I appear to have the latest 8 installed (8u351), which happened before I upgraded to Ventura. The Java Updater check ran pretty soon after I did the MacOS upgrade.

        Attachments

          1. crash1.txt
            12 kB
          2. crash3.txt
            10 kB
          3. Screenshot  2022-11-23 at 3.05.21 PM.png
            Screenshot 2022-11-23 at 3.05.21 PM.png
            74 kB
          4. updater-crash.png
            updater-crash.png
            39 kB

          Issue Links

            Activity

              People

                almatvee Alexander Matveev
                jeff Jeff Dinkins
                Votes:
                0 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved: