Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8286907 keytool should warn about weak PBE algorithms
  3. JDK-8301719

Release Note: `keytool -genseckey` And `-importpass` Commands Warn if Weak PBE Algorithms Are Used

    XMLWordPrintable

Details

    • Sub-task
    • Resolution: Delivered
    • P4
    • 21
    • 21
    • security-libs

    Description

      The `keytool` `-genseckey` and `-importpass` commands have been updated to warn users when weak password-based encryption algorithms are specified by the `-keyalg` option.

      Attachments

        Activity

          People

            hchao Haimay Chao
            hchao Haimay Chao
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: