Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8303883

Confusing parameter name in G1UpdateRemSetTrackingBeforeRebuild::distribute_marked_bytes

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Fixed
    • P5
    • 21
    • 21
    • hotspot
    • gc
    • b14

    Description

      G1UpdateRemSetTrackingBeforeRebuild::distribute_marked_bytes' second parameter is called marked_words, which is confusing wrt to the name of the method.

      Fix this naming issue (there is no actual bug, only confusing naming)

      Attachments

        Issue Links

          Activity

            People

              tschatzl Thomas Schatzl
              tschatzl Thomas Schatzl
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: