The Java version of Fdlibm would benefit from various refactorings including:
* Get rid of the rest of "one", "zero" fields
* Defining commonly used masks for SIGN_BIT, SIGN_EXP, HIGH_SIGNIF masks based on DoubleConst values.
Explore if added "unsignedLessThan" and "unsignedLessThanEQ" methods would be worthwhile rather than Integer.compareUnsigned.
* Get rid of the rest of "one", "zero" fields
* Defining commonly used masks for SIGN_BIT, SIGN_EXP, HIGH_SIGNIF masks based on DoubleConst values.
Explore if added "unsignedLessThan" and "unsignedLessThanEQ" methods would be worthwhile rather than Integer.compareUnsigned.
- relates to
-
JDK-8308049 Refactor nested class declarations in FdLibm.java
-
- Resolved
-