It would be better to have consistent naming, so we should make these name changes:
- "fetch_and_add" => "fetch_then_add"
- "add_and_fetch" => "add_then_fetch"
Note that there are currently no uses of "add_and_fetch" outside the implementation of Atomic. Also note that we don't currently have subtraction variants of either.
- relates to
-
JDK-8293117 Add atomic bitset functions
- Resolved