Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8309899

Rename PtrQueueSet::buffer_size()

    XMLWordPrintable

Details

    • gc
    • b02

    Description

      PtrQueueSet and the associated BufferNode::Allocator make the number of slots in a buffer available via the buffer_size() function. This is the capacity rather than the number of filled entries, which is the more usual meaning of "size" for such a data structure. It would be clearer if this were named buffer_capacity. Such a renaming would also leave naming room to in the future add a size operation that returned the number of filled entries.

      Attachments

        Issue Links

          Activity

            People

              kbarrett Kim Barrett
              kbarrett Kim Barrett
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: