While learning the NMT code I came across _mst_marker and I don't really care that it combines 16bit index and 16bit position into one 32bit mst_marker.
We need these extra 3 APIs: build_marker(), bucket_idx_from_marker(), pos_idx_from_marker()
They are really unnecessary, in my opinion, and in fact obfuscate the code.
I'd like to propose that we simplify the code and pass along index and position individually as needed. In my opinion, this makes the code easier to read and understand, with no need to explain what mst_marker is.
We need these extra 3 APIs: build_marker(), bucket_idx_from_marker(), pos_idx_from_marker()
They are really unnecessary, in my opinion, and in fact obfuscate the code.
I'd like to propose that we simplify the code and pass along index and position individually as needed. In my opinion, this makes the code easier to read and understand, with no need to explain what mst_marker is.
- relates to
-
JDK-8281015 Further simplify NMT backend
-
- Resolved
-
- links to
-
Review openjdk/jdk/15145