-
Bug
-
Resolution: Unresolved
-
P4
-
None
-
Fix Understood
-
generic
-
generic
While working on other issues which related to DigitList, I found that the current code and organization resulted in taking more time to understand the code than needed.
The class is quite old and can benefit from
- Re-organization (related methods should be coupled together)
- Odd for loops can be replaced with more explicit alternatives
- rounding logic should be combined
- modern annotations like (@Override)
- General comments, splitting up logic into separate methods
The class is quite old and can benefit from
- Re-organization (related methods should be coupled together)
- Odd for loops can be replaced with more explicit alternatives
- rounding logic should be combined
- modern annotations like (@Override)
- General comments, splitting up logic into separate methods