Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8316344

Re-package asm or at least use current version

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Unresolved
    • P4
    • None
    • None
    • core-libs
    • None

    Description

      The Nashorn 15.4 engine depends on asm version 7.3.1 from Jan 2020. Since then the world has moved on, asm is at v9.5 by now and other libraries depend on this newer asm version.

      It would be very helpful, if Nashorn either re-packaged (i.e. moved all classes to a different package) and integrated asm or at least became dependent on current versions of asm in order to avoid asm dependency version conflicts between Nashorn and other popular packages, for example jnr-ffi.

      Attachments

        Activity

          People

            Unassigned Unassigned
            hschreiber Hendrik Schreiber
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: