Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8324723

GHA: Upgrade some actions to avoid deprecated Node 16

    XMLWordPrintable

Details

    • b08

    Backports

      Description

        Current GHA runs produce lots of warnings:

        Node.js 16 actions are deprecated. Please update the following actions to use Node.js 20: actions/cache@v3, actions/download-artifact@v3, actions/upload-artifact@v3. For more information see: https://github.blog/changelog/2023-09-22-github-actions-transitioning-from-node-16-to-node-20/.

        We can upgrade to new actions to get the Node20.

        Release/migration notes:
        https://github.com/actions/cache#whats-new
        https://github.com/actions/upload-artifact/blob/main/docs/MIGRATION.md
        https://github.com/actions/download-artifact/blob/main/docs/MIGRATION.md

        There is also msys2/setup-msys2, which was pinned by JDK-8310259. We need at least 2.21.0 to get Node 20:
        https://github.com/msys2/setup-msys2/blob/main/CHANGELOG.md

        Attachments

          Issue Links

            Activity

              People

                shade Aleksey Shipilev
                shade Aleksey Shipilev
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved: