Supersedes https://bugs.openjdk.org/browse/JDK-8311864 as a result of a discussion in that issue's PR.
Goals:
* make vectorizedHashCode private and rename it to rid of "vectorized"
* provide a hashCode overload per primitive type to rid of client-facing constants, such as T_BOOLEAN, T_CHAR, etc.
* add a hashCode overload for Object[]
Goals:
* make vectorizedHashCode private and rename it to rid of "vectorized"
* provide a hashCode overload per primitive type to rid of client-facing constants, such as T_BOOLEAN, T_CHAR, etc.
* add a hashCode overload for Object[]
- relates to
-
JDK-8311864 Add ArraysSupport.hashCode(int[] a, fromIndex, length, initialValue)
-
- Closed
-