-
Enhancement
-
Resolution: Fixed
-
P5
-
None
-
b07
Static and non-static CSS.LengthUnit.getValue methods essentially do the same thing.
We can improve them:
1. delegate one to another to reduce code duplication.
2. use primitive boolean type as parameter to avoid boxing
3. take advantage of Map.getOrDefault() to simplify code further
We can improve them:
1. delegate one to another to reduce code duplication.
2. use primitive boolean type as parameter to avoid boxing
3. take advantage of Map.getOrDefault() to simplify code further
- links to
-
Commit(master) openjdk/jdk/93469847
-
Review(master) openjdk/jdk/21833