Uploaded image for project: 'Java Mission Control'
  1. Java Mission Control
  2. JMC-8121

JMC should fail properly when executed with <17 JDK

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • P4
    • 9.0.0
    • None
    • docs

    Description

      The "jmc.product" file currently doesn't state the minimally required JDK version to run via the osgi.requiredJavaVersion property. This leads to hard to comprehend error message when starting JMC with Java 8: Just a popup that tells us that some error occurred and the name of the log file, yet even the log file doesn't state the error clearly.

      Attachments

        Issue Links

          Activity

            People

              ssatish Savitha Satish
              jbechberger Johannes Bechberger
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: