When solving SKARA-1588, I noticed that GitLab deprecated the word `WIP` and renamed it to `draft`[1].
Previously, if the title of a GitLab merge request starts with `WIP: `, the GitLab would mark it as draft. Now, it should be started with `Draft: `.
And the fields `wip` and `work_in_progress`, which are returned by some GitLab Restful APIs, are deprecated, too. The new field `draft` is better. [2]
So the classes or methods about it, such as the mthods `makeNotDraft` and `isDraft` in class `GitLabMergeRequest`, should be adjusted to meet this new convention.
[1] https://docs.gitlab.com/ee/update/removals.html#wip-merge-requests-renamed-draft-merge-requests
[2] https://docs.gitlab.com/ee/api/merge_requests.html
Previously, if the title of a GitLab merge request starts with `WIP: `, the GitLab would mark it as draft. Now, it should be started with `Draft: `.
And the fields `wip` and `work_in_progress`, which are returned by some GitLab Restful APIs, are deprecated, too. The new field `draft` is better. [2]
So the classes or methods about it, such as the mthods `makeNotDraft` and `isDraft` in class `GitLabMergeRequest`, should be adjusted to meet this new convention.
[1] https://docs.gitlab.com/ee/update/removals.html#wip-merge-requests-renamed-draft-merge-requests
[2] https://docs.gitlab.com/ee/api/merge_requests.html