Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6649633

64 bit jdk and 32 bit jre do not install on amd/ia windows machine on first install.



    • b06
    • x86, itanium
    • windows


      How to reproduce:

      Just install any x64 jdk on an amd machine.

      When installing an x64 amd jdk on a windows machine a Windows Installer error dialog is shown is being thrown.

      An error dialog is shown with the following message:

      Error applying transforms. Verify that the specified transform are valid.

      If an attemp to install the jdk is done on a second time, the jdk will install with no errors.

      Snapshot attached:
      This issue can be seen on windows 2008 longhorn and windows 2003.
      This issue is mainly seen when installing 1.4.2 jdk on an amd machine running windows 2003 or windows 2008 (off line installation). Also the jdk should not have been installed before. I.e it should be the first time to install the type of 1.4.2 jdk on the machine.

      I have tried to install the i586 bundle and the installation was ok.

      I have a windows 2008 which can be used to reproduce this issue.

      The machine name is twirl.ireland and vnc password is .
      The amd 64 bundles is the problem and not the i586 bundle.

      I can reproduce this everytime i install an amd 64 bundle on a windows machine.

      The steps have been given. see description.
      Machine given for vnc .. login and password is not working.
      Received the same error during 32bit jdk silent installation on amd64 XP machine:
      INFO Starting installation
      DEBUG $ K:/vmsqe/stt/newroot/jdk/1.4.2_25/./rev/b03_j4b/bundles/windows-i586/j2sdkfb-1_4_2_25-rev-bin-b03-windows-i586-p-26_jan_2010.exe /v"/log K:\stt
      esults\1.4.2_2503_j4b\ir\install\winxp-x64-64\1.4.2_25_b03_j4b_winxp-x64-64_02\jdk-install.log /qn INSTALLDIR=C:\jdk\j2sdk1.4.2_25\windows-i586 REBOOT=Suppress" /s || res=$?

      JDK installation log is attached.
      x86 windows 2003 is also affected, see test results: http://vice.russia.sun.com/results/1.4.2_26/b02_j4b/install/install/win2003-x86-32/1.4.2_26_b02_j4b_win2003-x86-32_01/root.Windows_2003.x86/clean_1/
      Requesting to provide any machine where problem can be reproduced. The machine which is given is down.
      Removed non-public data from public field.


        Issue Links



              vchoudhaorcl Vaibhav Choudhary (Inactive)
              amoote Abdulkadir Moote (Inactive)
              0 Vote for this issue
              2 Start watching this issue