Continuing the discussion from RT-1344...
Bloom and Glow are similar effects, but in 1.0 their APIs are oversimplified, and it's not clear how the two effects differ.
Bloom is currently set up (behind the scenes) like this:
<pre><code>
//
// (input)
// |
// Brightpass
// |
// GaussianBlur
// |
// Crop (input)
// | |
// Blend
// |
//
</code></pre>
Glow is pretty much the same, except there's no Brightpass step (i.e., Brightpass.threshold = 1.0, which is essentially a no-op).
Both Glow and Bloom should be enhanced with variables to control those other effects (e.g. GaussianBlur) used internally.
Bloom {
public var threshold:Number; // controls Brightpass.threshold (already in 1.0)
public var level:Number; // controls Blend.opacity
public var radius:Number; // controls GaussianBlur.radius
public var includeFringes:Boolean; // controls GaussianBlur.includeFringes (see RT-1347)
}
Glow {
public var level:Number; // controls Blend.opacity (already in 1.0)
public var radius:Number; // controls GaussianBlur.radius
public var includeFringes:Boolean; // controls GaussianBlur.includeFringes (see RT-1347)
}
Maybe it would be better to deprecate Glow since:
- the name is a bit confusing and clashes with InnerGlow and OuterGlow (proposed in RT-399)
- the existing Glow effect can be simulated with Bloom { threshold: 1.0 }
Bloom and Glow are similar effects, but in 1.0 their APIs are oversimplified, and it's not clear how the two effects differ.
Bloom is currently set up (behind the scenes) like this:
<pre><code>
//
// (input)
// |
// Brightpass
// |
// GaussianBlur
// |
// Crop (input)
// | |
// Blend
// |
//
</code></pre>
Glow is pretty much the same, except there's no Brightpass step (i.e., Brightpass.threshold = 1.0, which is essentially a no-op).
Both Glow and Bloom should be enhanced with variables to control those other effects (e.g. GaussianBlur) used internally.
Bloom {
public var threshold:Number; // controls Brightpass.threshold (already in 1.0)
public var level:Number; // controls Blend.opacity
public var radius:Number; // controls GaussianBlur.radius
public var includeFringes:Boolean; // controls GaussianBlur.includeFringes (see RT-1347)
}
Glow {
public var level:Number; // controls Blend.opacity (already in 1.0)
public var radius:Number; // controls GaussianBlur.radius
public var includeFringes:Boolean; // controls GaussianBlur.includeFringes (see RT-1347)
}
Maybe it would be better to deprecate Glow since:
- the name is a bit confusing and clashes with InnerGlow and OuterGlow (proposed in RT-399)
- the existing Glow effect can be simulated with Bloom { threshold: 1.0 }