os::open presently has the following overloads:
int open(const char* pathname, int flags, int mode);
FILE* open(int fd, const char* mode);
The present 2-arg overload is really fdopen, and should be renamed accordingly. Two overloads in the same "namespace" with completely different semantics is just confusing, even more so withJDK-8218856.
(This suggestion came out of the review forJDK-8218811.)
int open(const char* pathname, int flags, int mode);
FILE* open(int fd, const char* mode);
The present 2-arg overload is really fdopen, and should be renamed accordingly. Two overloads in the same "namespace" with completely different semantics is just confusing, even more so with
(This suggestion came out of the review for