-
Enhancement
-
Resolution: Fixed
-
P4
-
None
-
repo-panama
Some names in the internal implementation of the linker could be improved.
I suggest the following renaming changes.
- ProgrammableInvoker -> DowncallLinker
- ProgrammableUpcallHandler -> UpcallLinker
- 'native invoker' -> 'downcall stub'
- 'optimzed upcall stub' -> 'upcall stub'
- OptimizedEntryBlob -> UpcallStub
- optimized_entry_frame -> upcall_stub_frame
Then renaming of some hotspot files:
- universalNativeInvoker* -> downcallLinker*
- universalUpcallHandler* -> upcallLinker*
- foreign_globals* -> foreignGlobals* (to match existing convention)
I suggest the following renaming changes.
- ProgrammableInvoker -> DowncallLinker
- ProgrammableUpcallHandler -> UpcallLinker
- 'native invoker' -> 'downcall stub'
- 'optimzed upcall stub' -> 'upcall stub'
- OptimizedEntryBlob -> UpcallStub
- optimized_entry_frame -> upcall_stub_frame
Then renaming of some hotspot files:
- universalNativeInvoker* -> downcallLinker*
- universalUpcallHandler* -> upcallLinker*
- foreign_globals* -> foreignGlobals* (to match existing convention)
- relates to
-
JDK-8286825 Linker naming cleanup
- Resolved