-
Enhancement
-
Resolution: Fixed
-
P4
-
19
-
None
Port JDK-8275648 to mainline.
Some names in the internal implementation of the linker could be improved.
I suggest the following renaming changes.
- ProgrammableInvoker -> DowncallLinker
- ProgrammableUpcallHandler -> UpcallLinker
- 'native invoker' -> 'downcall stub'
- 'optimzed entry blob' -> 'upcall stub'
- OptimizedEntryBlob -> UpcallStub
- optimized_entry_frame -> upcall_stub_frame
Then renaming of some hotspot files:
- universalNativeInvoker* -> downcallLinker*
- universalUpcallHandler* -> upcallLinker*
- foreign_globals* -> foreignGlobals* (to match existing convention)
Some names in the internal implementation of the linker could be improved.
I suggest the following renaming changes.
- ProgrammableInvoker -> DowncallLinker
- ProgrammableUpcallHandler -> UpcallLinker
- 'native invoker' -> 'downcall stub'
- 'optimzed entry blob' -> 'upcall stub'
- OptimizedEntryBlob -> UpcallStub
- optimized_entry_frame -> upcall_stub_frame
Then renaming of some hotspot files:
- universalNativeInvoker* -> downcallLinker*
- universalUpcallHandler* -> upcallLinker*
- foreign_globals* -> foreignGlobals* (to match existing convention)
- relates to
-
JDK-8275648 Linker naming bikeshed
-
- Resolved
-
-
JDK-8287194 build failure on riscv after JDK-8286825
-
- Resolved
-