Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4636303

Public JRE(1.3.x / 1.x ) installation fails when installed on existing J2SDK1.4

    XMLWordPrintable

Details

    • 04
    • x86
    • windows_98, windows_nt
    • Not verified

    Description

      OS : Windows
      JDK/JRE : JDK 1.3x / JDK 1.1x

      Steps To Reproduce:

      1.) Install J2SDK 1.4.0 (FCS)
      2.) Install J2SDK 1.3.0 over existing J2SDK 1.4.0 (FCS)

      Results :

      During the JDK 1.3.x installation process though it displays saying "Setting up Java 2 Runtime Environment " It will abort the public jre installation and no error messages will appear, resulting with no 1.3 Runtime on the system.

      Due to this problem the user cannot use JRE 1.3 bundled in JDK1.3 when installed over JDK1.4 and he would be forced to use JRE1.4 .

      Here is how the reg keys are pointed when J2SDK1_3_0 is installed over J2SDK1.4.0-FCS

      Reg Keys(JDK Current Version) : 1.3
      Reg Keys(JRE Current Version) : 1.4
      When you do java -version on command prompt shows "1.4"

      Attachments

        Issue Links

          Activity

            People

              billyh William Harnois
              smadishesunw Srinivas Madishetty (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: